Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2026 - 04:00 EDT
Scheduled
We will be going via a Version Update and Server Transition. Updates will be given in our discord as we continue through the process. The last reset on the old server will be on March 24th, 2026 at 5 AM (EST). The new server should have the new reset running on March 27th, 2026 at 5 AM (EST) unless issues come up.
Posted Mar 22, 2026 - 20:26 EDT
This scheduled maintenance affected: Secfenia Forums, Secfenia Main IG, Secfenia Tavern, and Secfenia Mobile.