Forum being taken offline for security updates
Incident Report for World of Secfenia
Resolved
This incident has been resolved.
Posted Feb 20, 2023 - 19:10 EST
Update
Forum Updates have been completed!
Posted Feb 20, 2023 - 19:10 EST
Investigating
We are currently applying some fixes for our forum software.
Posted Feb 20, 2023 - 18:21 EST
This incident affected: Secfenia Forums.